Error on Post Reply

Status
Not open for further replies.

Niro

New Member
Hi,

I got that :

  • XF\Db\DuplicateKeyException: MySQL query error [1062]: Duplicate entry 'thread-14729' for key 'content_type_content_id'
  • src/XF/Db/AbstractStatement.php:212


Could you please help me ?

Thanks!
 

Niro

New Member
Code:
INSERT  INTO `xf_tl_post_reply_root` (`content_type`, `content_id`, `root_id`, `item_count`, `item_cache`) VALUES (?, ?, ?, ?, ?)
------------

#0 src/XF/Db/Mysqli/Statement.php(196): XF\Db\AbstractStatement->getException('MySQL query err...', 1062, '23000')
#1 src/XF/Db/Mysqli/Statement.php(77): XF\Db\Mysqli\Statement->getException('MySQL query err...', 1062, '23000')
#2 src/XF/Db/AbstractAdapter.php(79): XF\Db\Mysqli\Statement->execute()
#3 src/XF/Db/AbstractAdapter.php(160): XF\Db\AbstractAdapter->query('INSERT  INTO `x...', Array)
#4 src/XF/Mvc/Entity/Entity.php(1409): XF\Db\AbstractAdapter->insert('xf_tl_post_repl...', Array, false)
#5 src/XF/Mvc/Entity/Entity.php(1141): XF\Mvc\Entity\Entity->_saveToSource()
#6 src/addons/Truonglv/PostReply/Repository/Item.php(88): XF\Mvc\Entity\Entity->save()
#7 src/addons/Truonglv/PostReply/XF/Entity/Post.php(74): Truonglv\PostReply\Repository\Item->onContainerInsert(Object(XFA\WhoReadThisThread\XF\Entity\Thread))
#8 src/addons/EWR/Discord/Entity/Post.php(11): Truonglv\PostReply\XF\Entity\Post->_postSave()
#9 src/addons/LiamW/ThreadSolutions/XF/Entity/Post.php(105): EWR\Discord\Entity\Post->_postSave()
#10 src/XF/Mvc/Entity/Entity.php(1165): LiamW\ThreadSolutions\XF\Entity\Post->_postSave()
#11 src/XF/Service/Thread/Replier.php(167): XF\Mvc\Entity\Entity->save(true, false)
#12 src/XF/Service/ValidateAndSavableTrait.php(40): XF\Service\Thread\Replier->_save()
#13 src/XF/Pub/Controller/Thread.php(454): XF\Service\Thread\Replier->save()
#14 src/XF/Mvc/Dispatcher.php(249): XF\Pub\Controller\Thread->actionAddReply(Object(XF\Mvc\ParameterBag))
#15 src/XF/Mvc/Dispatcher.php(88): XF\Mvc\Dispatcher->dispatchClass('XF:Thread', 'AddReply', 'json', Object(XF\Mvc\ParameterBag), 'forums', Object(XenConcept\HidePlugin\XF\Pub\Controller\Thread), NULL)
#16 src/XF/Mvc/Dispatcher.php(41): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#17 src/XF/App.php(1934): XF\Mvc\Dispatcher->run()
#18 src/XF.php(333): XF\App->run()
#19 index.php(13): XF::runApp('XF\\Pub\\App')
#20 {main}
 

Niro

New Member
Code:
array(4) {
  ["url"] => string(45) "/threads/hi-%C3%A0-everyone.14729/add-reply"
  ["referrer"] => string(57) "https://domain.com/threads/hi-%C3%A0-everyone.14729/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(9) {
    ["message_html"] => string(38) "<p>hi everybody</p>"
    ["attachment_hash"] => string(32) "3743f185760681b15c9b1f880b3b62de"
    ["attachment_hash_combined"] => string(87) "{"type":"post","context":{"thread_id":14729},"hash":"3743f185760681b15c9b1f880b3b62de"}"
    ["last_date"] => string(10) "1548167874"
    ["last_known_date"] => string(10) "1548167874"
    ["_xfToken"] => string(8) "********"
    ["_xfRequestUri"] => string(36) "/threads/hi-%C3%A0-everyone.14729/"
    ["_xfWithData"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}
 

Niro

New Member
Another thing please,


There is something touching the logo. Also, when an user reply to me, I do not receive alert. It is normal please ?

Thanks :)
 
Status
Not open for further replies.
Top