[FIXED] LogicException: Unknown relation or alias full accessed on xf_user

Brettflan

Member
This is with Social Groups 3.0.6, on XF v2.2.3 Patch 1.

The error in the server error log in the admin panel:
LogicException: Unknown relation or alias full accessed on xf_user - src/XF/Mvc/Entity/Finder.php:761
Stack trace:
Code:
#0 src/XF/Mvc/Entity/Finder.php(657): XF\Mvc\Entity\Finder->join('full', true, false, false)
#1 src/XF/Mvc/Entity/Manager.php(147): XF\Mvc\Entity\Finder->with('full')
#2 src/addons/Truonglv/Groups/Pub/Controller/Browse.php(158): XF\Mvc\Entity\Manager->find('XF:User', 518862, 'full')
#3 src/XF/Mvc/Dispatcher.php(350): Truonglv\Groups\Pub\Controller\Browse->actionUserFilters(Object(XF\Mvc\ParameterBag))
#4 src/XF/Mvc/Dispatcher.php(257): XF\Mvc\Dispatcher->dispatchClass('Truonglv\\Groups...', 'UserFilters', Object(XF\Mvc\RouteMatch), Object(Truonglv\Groups\Pub\Controller\Browse), NULL)
#5 src/XF/Mvc/Dispatcher.php(113): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(Truonglv\Groups\Pub\Controller\Browse), NULL)
#6 src/XF/Mvc/Dispatcher.php(55): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#7 src/XF/App.php(2326): XF\Mvc\Dispatcher->run()
#8 src/XF.php(488): XF\App->run()
#9 index.php(20): XF::runApp('XF\\Pub\\App')
#10 {main}
Request state:
Code:
array(4) {
  ["url"] => string(198) "/index.php?groups/browse/user/filters&user_id=518862&_xfRequestUri=%2Findex.php%3Fmembers%2Fmarryc.518862%2F&_xfWithData=1&_xfToken=<removed>&_xfResponseType=json"
  ["referrer"] => string(62) "https://forums.taleworlds.com/index.php?members/marryc.518862/"
  ["_GET"] => array(6) {
    ["groups/browse/user/filters"] => string(0) ""
    ["user_id"] => string(6) "518862"
    ["_xfRequestUri"] => string(33) "/index.php?members/marryc.518862/"
    ["_xfWithData"] => string(1) "1"
    ["_xfToken"] => string(43) "<removed>"
    ["_xfResponseType"] => string(4) "json"
  }
  ["_POST"] => array(0) {
  }
}

After brief testing I was able to reproduce the error by visiting a user's profile page, going to the Groups section where at least one group is listed, and clicking the Filters dropdown on the right. It then throws an error as above. If the user is not in any groups, then the Filters dropdown opens without error.
 

Truonglv

♥♥ √εgετα ♥♥
Staff member
Tech Support
It's fixed now.
 

hihi3979

New Member
test app hi
 

Thread view new threads

Top