1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AddOn Image Optimizer [Paid] 1.2.0

Optimize all attachments in your forum to save disk space.

  1. Nobita

    Nobita Staff Member Tech Support

    Messages:
    3,024
    Likes Received:
    1,140
    Trophy Points:
    113
  2. TravisTest

    TravisTest New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi i believe im doing something wrong I ran the optimizer said it prossese 2529 image with 0 fails but the log is showing 0% would you be able to take a look and help me?
    Screenshot_7.jpg
     
  3. Nobita

    Nobita Staff Member Tech Support

    Messages:
    3,024
    Likes Received:
    1,140
    Trophy Points:
    113
    Does you see any errors in Sever Error Log?
     
  4. TravisTest

    TravisTest New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    ErrorException: Undefined index: lastRunTime - library/Nobita/ImageOptimizer/Deferred/Optimize.php:45
    Generated By: Unknown Account, Today at 2:53 AM
    Stack Trace
    #0 /home/travisbourbeau/public_html/travisbourbeau.com/forum/library/Nobita/ImageOptimizer/Deferred/Optimize.php(45): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/travisbou...', 45, Array)
    #1 /home/travisbourbeau/public_html/travisbourbeau.com/forum/library/XenForo/Model/Deferred.php(295): Nobita_ImageOptimizer_Deferred_Optimize->execute(Array, Array, 7.9999969005585, '')
    #2 /home/travisbourbeau/public_html/travisbourbeau.com/forum/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.9999969005585, '', false)
    #3 /home/travisbourbeau/public_html/travisbourbeau.com/forum/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #4 /home/travisbourbeau/public_html/travisbourbeau.com/forum/deferred.php(23): XenForo_Model_Deferred->run(false)
    #5 {main}
    Request State
    array(3) {
    ["url"] => string(48) "http://www.travisbourbeau.com/forum/deferred.php"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(4) {
    ["_xfRequestUri"] => string(35) "/forum/admin.php?tools/run-deferred"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"
    }
    }

    Delete...Close
     
  5. TravisTest

    TravisTest New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I also dont know if this is set up wrong
     

    Attached Files:

  6. JPATS

    JPATS New Member

    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    1
    @TravisTest@TravisTest did you get yours working? Having similar issues, it runs but no logs and nothing optimized.
     
  7. JPATS

    JPATS New Member

    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    1
    Getting a very similar error, nothing in the logs and nothing optimized.
     
  8. arboristsite

    arboristsite New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I'm getting same error. Did Nobita fix it for you?
     
  9. JPATS

    JPATS New Member

    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    1
    He told me to ignore it. I guess it only happens on the very first run.
    Is yours producing any logs? Running?
     
  10. arboristsite

    arboristsite New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Same log as yours. I'm using cPanel but don't see any file has been optimized yet. Should I wait few minutes?
     
  11. JPATS

    JPATS New Member

    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    1
    Start a conversation with @Nobita@Nobita, he will help you out. He got mine working.
     
  12. JPATS

    JPATS New Member

    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    1
    He gave me new files jpegoptim, gifsicle, and pngquant, uninstalled and reinstalled the mod and it started working instantly.
     
    Breixo likes this.
  13. Nobita

    Nobita Staff Member Tech Support

    Messages:
    3,024
    Likes Received:
    1,140
    Trophy Points:
    113
  14. Nobita

    Nobita Staff Member Tech Support

    Messages:
    3,024
    Likes Received:
    1,140
    Trophy Points:
    113
    Breixo likes this.
  15. arboristsite

    arboristsite New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
  16. Nobita

    Nobita Staff Member Tech Support

    Messages:
    3,024
    Likes Received:
    1,140
    Trophy Points:
    113
    Yup. My addon does not modify the binary in your own server
     
  17. Nobita

    Nobita Staff Member Tech Support

    Messages:
    3,024
    Likes Received:
    1,140
    Trophy Points:
    113