Image Optimizer for XF 2.0

Image Optimizer for XF 2.0 [Paid] 2.1.8

PayPal: $29.00
Definitely after several tests I can confirm that Optimize images on fly does not work when you create a post with images. The images remain the same until the cron ([tl] Image Optimizer: Trigger Jobs) processes them. This option may only work with attached images. I hope this can be fixed.

On the other hand it would be great if Truonglv added an option to convert all proxy images stored in webp. Some of us store proxy images indefinitely and it would be a great help to reduce space and gain performance.

Greetings.
 
Definitely after several tests I can confirm that Optimize images on fly does not work when you create a post with images. The images remain the same until the cron ([tl] Image Optimizer: Trigger Jobs) processes them. This option may only work with attached images. I hope this can be fixed.

On the other hand it would be great if Truonglv added an option to convert all proxy images stored in webp. Some of us store proxy images indefinitely and it would be a great help to reduce space and gain performance.

Greetings.
Merino88this add-on does not support webp yet. I think I can add support it in next version.
 
For those interested... if you are running AlmaLinux 8 and the BETA of CentMin Mod.. this add-on will work. If you base it off of the versioning of software required in the notes.. you won't "meet" those expectations... but AlmaLinux 8 and the BETA of CentMin Mod works fine with it.
TD PerryI think Truonglv only set those version requirements for what he's tested with on Ubuntu so probably unaware if EL8/EL9 versions work or not.

TD Perry duderuud if you're on AlmaLinux/Rocky Linux or just don't want to build pngquant v3 with rustic installed but want pngquant v3, I did create a standalone static pngquant 3 binary which you can download and extract to the appropriate directory and give it executable permissions (chmod +x) https://github.com/centminmod/centminmod-pngquant3/releases/tag/3.0.3 :)
 
Last edited:
I think Truonglv only set those version requirements for what he's tested with on Ubuntu so probably unaware if EL8/EL9 versions work or not.

TD Perry duderuud if you're on AlmaLinux/Rocky Linux or just don't want to build pngquant v3 with rustic installed but want pngquant v3, I did create a standalone static pngquant 3 binary which you can download extra to the appropriate directory and give it executable permissions (chmod +x) https://github.com/centminmod/centminmod-pngquant3/releases/tag/3.0.3 :)
eva2000thank you for sharing.
 
Is the libwebp library necessary? It looks like I won't be able to use the webp option because I'm on a shared server. They don't want to install the library because it would affect the entire server.

Pngquant, jpegoptim and gifsicle were installed a long time ago and it works perfectly.

Isn't there an alternative way to use optimization and conversion to webp on a shared server?

Greetings.
 
Is the libwebp library necessary? It looks like I won't be able to use the webp option because I'm on a shared server. They don't want to install the library because it would affect the entire server.

Pngquant, jpegoptim and gifsicle were installed a long time ago and it works perfectly.

Isn't there an alternative way to use optimization and conversion to webp on a shared server?

Greetings.
Merino88Yes. It's required like PNG and JPEG.
 
Back
Top