[FIXED] Discussion forum thread permissions

Brettflan

Member
Thanks for adding those permissions, they're a huge step forward. :)

After a bit of testing, I've run into a couple of issues, though.

1. "Undelete thread posts" / "View deleted posts" permissions don't work correctly. A regular user (not actual forum admin/moderator) with a group role that grants those permissions can see that the deleted post is there, but clicking the "Show" link on the deleted post pops up an error "Oops! We ran into some problems. The requested post could not be found". As a result, they can't see the contents of the post or see the option to undelete it.

2. "Delete threads any": not directly a bug, but rather a request. Could we get role permissions to view deleted threads and to be able to undelete threads? As it stands, they can soft-delete the threads, but can't recover those threads without the assistance of a super moderator. No worries if it's too much trouble, but it would be useful.

Again though, thanks a bunch for adding these permissions.
 

Brettflan

Member
OK, we've run into a further more problematic bug. It seems that while the thread permissions work for group moderators (other than the above exceptions), for some reason they do not work at all for group admins. This is again with a regular user who is set as either a group admin or group moderator, within that group's discussion forum.

For reference, the permissions I have set for the moderator role:
moderator_role.png
And the dropdown of options available within the thread for that role, showing the appropriate options:
moderator_options.png

Then these are the permissions I have set for the admin role:
admin_role.png
And here is what the admin role sees in the thread dropdown (in this instance as the thread author, thus the two options that do actually show up are for that reason):
admin_options.png

I've even tried setting all thread permissions enabled for both roles, but the thread dropdown for each role remains as above, with the group moderator role still having those options correctly available, and the group admin role not having any of the options working. So the problem does seem to be somehow tied to the admin role specifically, for whatever reason.
 

Brettflan

Member
Update: we've found a strange workaround. If the regular user who is a group admin has their role changed to group moderator, they get the working thread permissions associated with group moderator. Nothing particularly surprising there. However, if the user is then switched back to group admin, the thread permissions associated with group admin are suddenly working properly. The process of switching the user from group admin to group moderator and then back to group admin apparently fixes the problem.

I thought it might be associated with the boards being created after the person is in the role, so I created another board for the same group, but the group admin (who was switched to group moderator and back) still has thread permissions in the new board. So that's not it.

So it seems to be a problem specifically with users that start out as group admin and don't have their role changed. Their thread permissions don't work until their role is changed.

I'm 90% sure I ran all cache refreshes available related to this addon, so I don't think that is it.

Further, with the same test user as above who had fixed thread permissions by having their role switched from group admin->moderator->admin, I created another test group by that user and a board within that new group. Sure enough, thread permissions are not working in this new group and new group forum. So it should be easy enough for you to reproduce.
 

Brettflan

Member
Another update: changing the group's privacy breaks all thread permissions, for group admins and group moderators. Switching the user's role away and back to admin or moderator then restores functionality of thread permissions again.
 
Last edited:
Top