XenForo Store: Themes, add-ons and supporting

A collection add-ons to make your xenforo forums better
J
jakieqad
  1. Resolved
[NOT A BUG]RuntimeException issue can you take a look

Totoro

Staff member
Tech Support
Your server has been disabled shell exec while it is required by this addon. So you may ask your host to enable it
 
hollosch
hollosch
  1. Resolved
[NOT A BUG]can't add forum
hollosch
hollosch
  1. Resolved
[NOT A BUG]Error using Media

hollosch

Member
Click the media-link in gruop following error:

XF\Db\Exception: MySQL statement prepare error [1054]: Unknown column 'xf_mg_album.tl_group_id' in 'where clause' in src/XF/Db/AbstractStatement.php at line 212
  1. XF\Db\AbstractStatement->getException() in src/XF/Db/Mysqli/Statement.php at line 196
  2. XF\Db\Mysqli\Statement->getException() in src/XF/Db/Mysqli/Statement.php at line 39
  3. XF\Db\Mysqli\Statement->prepare() in src/XF/Db/Mysqli/Statement.php at line 54
  4. XF\Db\Mysqli\Statement->execute() in src/XF/Db/AbstractAdapter.php at line 79
  5. XF\Db\AbstractAdapter->query() in src/XF/Db/AbstractAdapter.php at line 91
  6. XF\Db\AbstractAdapter->fetchOne() in src/XF/Mvc/Entity/Finder.php at line 1118
  7. XF\Mvc\Entity\Finder->total() in src/addons/XFMG/ControllerPlugin/AlbumList.php at line 31
  8. XFMG\ControllerPlugin\AlbumList->getAlbumListData() in src/addons/Truonglv/Groups/Pub/Controller/Group.php at line 188
  9. Truonglv\Groups\Pub\Controller\Group->actionMedia() in src/XF/Mvc/Dispatcher.php at line 249
  10. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 88
  11. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 41
  12. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1934
  13. XF\App->run() in src/XF.php at line 333
  14. XF::runApp() in index.php at line 13
 
J
janslu
  1. Resolved
[NOT A BUG]Visibility of discussion forums on Tapatalk

janslu

Member
I have an issue with Tapatalk application, where discussion forums become visible in the list of forums even though they are under a "hidden" forum (archive group forums...). Do you have any idea what I should tell them to do? Should they verify node type before displaying/listing?
 

janslu

Member
Hi @truonglv I got more information from my users and here's what is going on... Group discussions on tapatalk are hidden and it works as it should. But when users are subscribed to groups, they can enter to discussion threads through notifications. On XF1 they were able to enter through those notification links and reply to discussions in group discussions (I had no idea it works). But on XF 2.0 when they enter the discussion forum through notification, they can see posts (as before) but when they try to reply there's an error: "Need valid forum id!".

I will post a bug to tapatalk, but I also want to ask you if you think this may be "fixed" on your side?
 
Last edited:
Ranger375
Ranger375
  1. Resolved
[FIXED]Download issue
View previous replies…

Ranger375

Member
So this issue is now occuring with the latest release. I was able to download the last one after you fixed it, but this is what happens with the latest:

error.png
 
hollosch
hollosch
  1. Resolved
[FIXED]ErrorException: [E_WARNING] fopen(data/nobita/teams/avatars/0/13.jpg): failed to open stream: No such file or directory src/XF/Util/File.php:100

hollosch

Member
#0 [internal function]: XF::handlePhpError(2, '[E_WARNING] fop...', '/data/vhosts/re...', 100, Array)
#1 src/XF/Util/File.php(100): fopen('data/nobita/tea...', 'r')
#2 src/addons/Truonglv/Groups/Import/Importer/Group.php(232): XF\Util\File::copyFileToAbstractedPath('data/nobita/tea...', 'data://groups/a...')
#3 src/addons/Truonglv/Groups/Import/Importer/Group.php(156): Truonglv\Groups\Import\Importer\Group->importGroup(Array)
#4 src/XF/Import/Runner.php(160): Truonglv\Groups\Import\Importer\Group->stepGroups(Object(XF\Import\StepState), Array, 8)
#5 src/XF/Import/Runner.php(74): XF\Import\Runner->runStep('groups', Object(XF\Import\StepState), 8)
#6 src/XF/Admin/Controller/Import.php(232): XF\Import\Runner->run()
#7 src/XF/Mvc/Dispatcher.php(249): XF\Admin\Controller\Import->actionRun(Object(XF\Mvc\ParameterBag))
#8 src/XF/Mvc/Dispatcher.php(88): XF\Mvc\Dispatcher->dispatchClass('XF:Import', 'Run', 'html', Object(XF\Mvc\ParameterBag), 'importData', Object(XF\Admin\Controller\Import), NULL)
#9 src/XF/Mvc/Dispatcher.php(41): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#10 src/XF/App.php(1931): XF\Mvc\Dispatcher->run()
#11 src/XF.php(329): XF\App->run()
#12 admin.php(13): XF::runApp('XF\\Admin\\App')
#13 {main}


What can i do?
 
B
barefoot
  1. Resolved
[FIXED]ErrorException: Template error: Cannot call method canUploadMedia on a non-object (NULL)

barefoot

Member
I'm seeing this error in my Server Error Logs. It seems to be from users who are not logged in trying to add a new album.

Code:
ErrorException: Template error: Cannot call method canUploadMedia on a non-object (NULL) src/XF/Template/Templater.php:927

Generated by: Unknown account Dec 11, 2018 at 3:36 PM

Stack trace

#0 [internal function]: XF\Template\Templater->handleTemplateError(512, 'Cannot call met...', '/home/***/publi...', 927, Array)
#1 src/XF/Template/Templater.php(927): trigger_error('Cannot call met...', 512)
#2 internal_data/code_cache/templates/l1/s1/public/tl_groups_media_album_create.php(34): XF\Template\Templater->method(NULL, 'canUploadMedia', Array)
#3 src/XF/Template/Templater.php(1250): XF\Template\Templater->{closure}(Object(XF\Template\Templater), Array)
#4 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('tl_groups_media...', Array)
#5 src/XF/Mvc/Renderer/Html.php(48): XF\Template\Template->render()
#6 src/XF/Mvc/Dispatcher.php(332): XF\Mvc\Renderer\Html->renderView('XF:Error\\Regist...', 'public:tl_group...', Array)
#7 src/XF/Mvc/Dispatcher.php(303): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#8 src/XF/Mvc/Dispatcher.php(44): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#9 src/XF/App.php(1931): XF\Mvc\Dispatcher->run()
#10 src/XF.php(329): XF\App->run()
#11 index.php(13): XF::runApp('XF\\Pub\\App')
#12 {main}

Request state
   
array(4) {
  ["url"] => string(31) "/media/albums/create?group_id=9"
  ["referrer"] => bool(false)
  ["_GET"] => array(1) {
    ["group_id"] => string(1) "9"
  }
  ["_POST"] => array(0) {
  }
}
How to recreate this error:
I can recreate this error when I am not logged into my forum. I then navigate to a group and click on Media. I then click Add Album and it shows me the input boxes Album title and Album Description (without the upload media icons). I type in the input boxes and then press Save and it throws the error in the server error log.

It seems to me that there is a permissions error here. Guest users should not be able to create albums.

Similar error:
There's a thread on xenforo.com which seems to discuss a similar problem with another plugin: https://xenforo.com/community/threads/template-error-cannot-call-method-isignoring-on-a-non-object-null.153714/
 
Last edited:
J
janslu
  1. Resolved
[NOT A BUG]XF 2.0.11 1.0.8 import from XF 1.5 group nodes still visible on main forum page

janslu

Member
I am running test upgrades to finally upgrade my forum to XF 2.0. Earlier test on 1.0.7a were fine, but then tests on 1.0.7b and 1.0.8 seem to import content fine and without a problem, but I cannot get group nodes to disappear from forum homepage.

Here's my setup:

1. Archive group forums to node is set up to a specific node (it is a first one among "normal" nodes, sorting = 1):
Screenshot 2018-11-25 at 20.31.57.png

This node has Display in the node list set to OFF

And my front page is still full of Groups forums...

No errors in the log...

Tried rebuilding forum cache, different groups cache, permissions cache etc. Nothing changes.

Any idea what could be a reason here?
 
View previous replies…

janslu

Member
@truonglv can you tell me what can be done to enable Social Groups working with Question & Answer Forums? ThemeHouse support is super slow from my experience, and if there's something needed from them, I need to know asap... If there's any way you can fix this on your own, that would be great.

As for the import thing - I made some other tests using also older versions and I just couldn't get them to work. What's interesting is that new groups may have new discussion threads added, but imported groups cannot. Let me know if I can help you in any way.
 

Totoro

Staff member
Tech Support
It's actually an bug from that add-on. Seem they has take all forums and display it. By default XF does not.
 
J
Jackko
  1. Resolved
[FIXED]Cannot create events, "requested group could not be found".

Jackko

New Member
I am using V 1.0.7b - If I try to create an event I get the error " requested group could not be found. "
If I then enable Friendly URL I get the following errors:

XF\Db\Exception: MySQL query error [1264]: Out of range value for column 'longitude' at row 1 in src/XF/Db/AbstractStatement.php at line 212



  1. XF\Db\AbstractStatement->getException() in src/XF/Db/Mysqli/Statement.php at line 196

  2. XF\Db\Mysqli\Statement->getException() in src/XF/Db/Mysqli/Statement.php at line 78

  3. XF\Db\Mysqli\Statement->execute() in src/XF/Db/AbstractAdapter.php at line 79

  4. XF\Db\AbstractAdapter->query() in src/XF/Db/AbstractAdapter.php at line 161

  5. XF\Db\AbstractAdapter->insert() in src/XF/Mvc/Entity/Entity.php at line 1403

  6. XF\Mvc\Entity\Entity->_saveToSource() in src/XF/Mvc/Entity/Entity.php at line 1135

  7. XF\Mvc\Entity\Entity->save() in src/addons/Truonglv/Groups/Service/Event/Creator.php at line 126

  8. Truonglv\Groups\Service\Event\Creator->_save() in src/XF/Service/ValidateAndSavableTrait.php at line 40

  9. Truonglv\Groups\Service\Event\Creator->save() in src/addons/Truonglv/Groups/Pub/Controller/Event.php at line 215

  10. Truonglv\Groups\Pub\Controller\Event->actionAdd() in src/XF/Mvc/Dispatcher.php at line 249

  11. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 89

  12. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 41

  13. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1931

  14. XF\App->run() in src/XF.php at line 329

  15. XF::runApp() in index.php at line 13
Also I cannot create a Forum as the node dropdown list is empty.
 
Last edited:
View previous replies…

Totoro

Staff member
Tech Support
Hi @Jackko
For temporary fix please run the following queries:
Code:
ALTER TABLE `xf_tl_group_event` CHANGE `latitude` `latitude` DECIMAL(11, 7) NOT NULL
Code:
ALTER TABLE `xf_tl_group_event` CHANGE `longitude` `longitude` DECIMAL(11, 7) NOT NULL
 
J
Joezilla
  1. Resolved
[NOT A BUG]Requested group could not be found.
View previous replies…

Jackko

New Member
  • Deleted by Jackko
  • Reason: by mistake I put it in the resolved section, will reopen ein the correct forum
I am using V 1.0.7b and have a similar Problem as Joezilla - If I try to create an event I get " Requested group could not be found. "
If I then enable Friendly URL I get errors:

XF\Db\Exception: MySQL query error [1264]: Out of range value for column 'longitude' at row 1 in src/XF/Db/AbstractStatement.php at line 212

  1. XF\Db\AbstractStatement->getException() in src/XF/Db/Mysqli/Statement.php at line 196
  2. XF\Db\Mysqli\Statement->getException() in src/XF/Db/Mysqli/Statement.php at line 78
  3. XF\Db\Mysqli\Statement->execute() in src/XF/Db/AbstractAdapter.php at line 79
  4. XF\Db\AbstractAdapter->query() in src/XF/Db/AbstractAdapter.php at line 161
  5. XF\Db\AbstractAdapter->insert() in src/XF/Mvc/Entity/Entity.php at line 1403
  6. XF\Mvc\Entity\Entity->_saveToSource() in src/XF/Mvc/Entity/Entity.php at line 1135
  7. XF\Mvc\Entity\Entity->save() in src/addons/Truonglv/Groups/Service/Event/Creator.php at line 126
  8. Truonglv\Groups\Service\Event\Creator->_save() in src/XF/Service/ValidateAndSavableTrait.php at line 40
  9. Truonglv\Groups\Service\Event\Creator->save() in src/addons/Truonglv/Groups/Pub/Controller/Event.php at line 215
  10. Truonglv\Groups\Pub\Controller\Event->actionAdd() in src/XF/Mvc/Dispatcher.php at line 249
  11. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 89
  12. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 41
  13. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1931
  14. XF\App->run() in src/XF.php at line 329
  15. XF::runApp() in index.php at line 13
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
24,726
Messages
30,786
Members
2,301
Latest member
Test-20190223
Top